HSTS-IIS-Module v1.0.2.0

Rating:        Based on 1 rating
Reviewed:  1 review
Downloads: 781
Change Set: 31570
Released: Jan 29, 2014
Updated: Jan 29, 2014 by shane_argo
Dev status: Stable Help Icon

Recommended Download

Application HSTS-IIS-Module x64 Installer v1.0.2.0
application, 376K, uploaded Jan 29 - 719 downloads

Other Available Downloads

Application HSTS-IIS-Module DLL v1.0.1.0 (Any CPU)
application, 13K, uploaded Jan 29 - 62 downloads

Release Notes

This is a minor update to fix several bugs reported by denache. Thank you.
  • The installer will now install over the top of old versions, instead of refusing to install until the older version is manually uninstalled.
  • Fixed a bug with the v1.0.1.0 installer which referred to the wrong DLL version.
  • Fixed a bug when constructing the HSTS header which resulted in a malformed header.

Requirements
This module will require IIS7.0+ as the module API was introduced in this version.

No x86 installer has been built as the only configuration that could utilise it would be Windows Server 2008 RTM (x86). If the demand is high, or someone submits an installer this may change. The module should work on this configuration if manually configured.

Testing
This has been tested on IIS7.5 on Server 2008 R2 (x64). Please let me know if you test this on any other configuration.

Reviews for this release

     
Worked perfectly fine on IIS 8.5 (Windows Server 2012 R2). The installer worked without any problems and the module was loaded in IIS management interface upon launch. HSTS was enabled easily through the module in the IIS management interface and didn't require a restart of the site. Thank you for taking the time to create this little gem :).
by jbnixx on Jul 8 at 11:18 AM